tanakahdaのプログラマ手帳

プログラミングとかソフトウェア開発とかの備忘録

pipで依存関係の問題を出力する@Python

pip check
spyder 5.1.5 requires pyqt5, which is not installed.
spyder 5.1.5 requires pyqtwebengine, which is not installed.
daal4py 2021.3.0 requires daal, which is not installed.
conda-repo-cli 1.0.4 requires pathlib, which is not installed.
applaunchservices 0.2.1 requires pyobjc, which is not installed.
anaconda-project 0.10.1 requires ruamel-yaml, which is not installed.
thinc-apple-ops 0.1.3 has requirement thinc<9.1.0,>=8.1.0.dev2, but you have thinc 8.0.17.
spacy-transformers 1.1.3 has requirement spacy<4.0.0,>=3.1.3, but you have spacy 3.0.0.
numba 0.54.1 has requirement numpy<1.21,>=1.17, but you have numpy 1.24.1.
ja-ginza 5.1.3 has requirement spacy<3.7.0,>=3.2.0, but you have spacy 3.0.0.
ja-ginza-electra 5.1.2 has requirement spacy<3.5.0,>=3.2.0, but you have spacy 3.0.0.
ja-core-news-lg 3.2.0 has requirement spacy<3.3.0,>=3.2.0, but you have spacy 3.0.0.
ginza 5.1.2 has requirement spacy<3.5.0,>=3.2.0, but you have spacy 3.0.0.
Note: you may need to restart the kernel to use updated packages.